using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:\.\d+)?k|(\d+(?:\.\d+)?)";
string input = @"28k ring to be worn 90w20h 96k watch final price
28k ring to be worn 90.8w20.6h 96k watch final price
28k ring to be worn 90.8 w 20.6h 96k watch final price
28k ring to be worn 90.8 20.6h 96k watch final price";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}