#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\\bin\\.*\\.*[Tt]ests\.dll$"
Local $sString = "C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\release\TestProject.API.Manager.tests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\release\TestProject.API.Manager.unittests.dll" & @CRLF & _
"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\SomeProject.dll"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")