package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\\bin\\.*\\.*[Tt]ests\.dll$`)
var str = `C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\release\TestProject.API.Manager.tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\release\TestProject.API.Manager.unittests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\SomeProject.dll`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}