import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\\\bin\\\\.*\\\\.*[Tt]ests\\.dll$";
final String string = "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll\n"
+ "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll\n"
+ "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\release\\TestProject.API.Manager.tests.dll\n"
+ "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\release\\TestProject.API.Manager.unittests.dll\n"
+ "C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\SomeProject.dll";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}