using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\\bin\\.*\\.*[Tt]ests\.dll$";
string input = @"C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Release\TestProject.API.Manager.Tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\Release\TestProject.API.Manager.UnitTests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\debug\TestProject.API.Manager.Tests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\release\TestProject.API.Manager.tests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\debug\TestProject.API.Manager.UnitTests.dll C:\ProjectFolder\TestProject\TestProject.API.Manager.UnitTests\bin\release\TestProject.API.Manager.unittests.dll
C:\ProjectFolder\TestProject\TestProject.API.Manager.Tests\bin\Debug\SomeProject.dll";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}