import re
regex = re.compile(r"^.*\\bin\\.*\\.*[Tt]ests\.dll$", flags=re.MULTILINE)
test_str = ("C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll\n"
"C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll\n"
"C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\release\\TestProject.API.Manager.tests.dll\n"
"C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\release\\TestProject.API.Manager.unittests.dll\n"
"C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\SomeProject.dll")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")