re = /^.*\\bin\\.*\\.*[Tt]ests\.dll$/m
str = 'C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Release\\TestProject.API.Manager.Tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\Release\\TestProject.API.Manager.UnitTests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\debug\\TestProject.API.Manager.Tests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\release\\TestProject.API.Manager.tests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\debug\\TestProject.API.Manager.UnitTests.dll C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.UnitTests\\bin\\release\\TestProject.API.Manager.unittests.dll
C:\\ProjectFolder\\TestProject\\TestProject.API.Manager.Tests\\bin\\Debug\\SomeProject.dll'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end