# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(benz\s+[[:alpha:]]+)\d\w*/\1/gm;t' <<< "2010 mercedes-benz sl500r
2010 mercedes-benz e550
2010 mercedes-benz glk350
2010 mercedes-benz c300w
2010 mercedes-benz 300
(\"2010 mercedes-benz sl\",
\"2020 mercedes-benz e\",
\"2017 mercedes-benz glk\",
\"2013 mercedes-benz c\",
\"2014 mercedes-benz 300\")"