# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(benz\s+[[:alpha:]]+)\d\w*"
test_str = ("2010 mercedes-benz sl500r\n"
"2010 mercedes-benz e550\n"
"2010 mercedes-benz glk350\n"
"2010 mercedes-benz c300w\n"
"2010 mercedes-benz 300\n\n"
"(\"2010 mercedes-benz sl\",\n"
" \"2020 mercedes-benz e\",\n"
" \"2017 mercedes-benz glk\",\n"
" \"2013 mercedes-benz c\",\n"
" \"2014 mercedes-benz 300\")")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.