import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(benz\\s+[[:alpha:]]+)\\d\\w*";
final String string = "2010 mercedes-benz sl500r\n"
+ "2010 mercedes-benz e550\n"
+ "2010 mercedes-benz glk350\n"
+ "2010 mercedes-benz c300w\n"
+ "2010 mercedes-benz 300\n\n"
+ "(\"2010 mercedes-benz sl\",\n"
+ " \"2020 mercedes-benz e\",\n"
+ " \"2017 mercedes-benz glk\",\n"
+ " \"2013 mercedes-benz c\",\n"
+ " \"2014 mercedes-benz 300\")";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}