re = /(benz\s+[[:alpha:]]+)\d\w*/m
str = '2010 mercedes-benz sl500r
2010 mercedes-benz e550
2010 mercedes-benz glk350
2010 mercedes-benz c300w
2010 mercedes-benz 300
("2010 mercedes-benz sl",
"2020 mercedes-benz e",
"2017 mercedes-benz glk",
"2013 mercedes-benz c",
"2014 mercedes-benz 300")'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result