const regex = /(benz\s+[[:alpha:]]+)\d\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(benz\\s+[[:alpha:]]+)\\d\\w*', 'gm')
const str = `2010 mercedes-benz sl500r
2010 mercedes-benz e550
2010 mercedes-benz glk350
2010 mercedes-benz c300w
2010 mercedes-benz 300
("2010 mercedes-benz sl",
"2020 mercedes-benz e",
"2017 mercedes-benz glk",
"2013 mercedes-benz c",
"2014 mercedes-benz 300")`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);