use strict;
my $str = '2010 mercedes-benz sl500r
2010 mercedes-benz e550
2010 mercedes-benz glk350
2010 mercedes-benz c300w
2010 mercedes-benz 300
("2010 mercedes-benz sl",
"2020 mercedes-benz e",
"2017 mercedes-benz glk",
"2013 mercedes-benz c",
"2014 mercedes-benz 300")';
my $regex = qr/(benz\s+[[:alpha:]]+)\d\w*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";