#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(benz\s+[[:alpha:]]+)\d\w*"
Local $sString = "2010 mercedes-benz sl500r" & @CRLF & _
"2010 mercedes-benz e550" & @CRLF & _
"2010 mercedes-benz glk350" & @CRLF & _
"2010 mercedes-benz c300w" & @CRLF & _
"2010 mercedes-benz 300" & @CRLF & _
"" & @CRLF & _
"("2010 mercedes-benz sl"," & @CRLF & _
" "2020 mercedes-benz e"," & @CRLF & _
" "2017 mercedes-benz glk"," & @CRLF & _
" "2013 mercedes-benz c"," & @CRLF & _
" "2014 mercedes-benz 300")"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)