using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)";
string input = @"Examples: 0.9 mg, 9 mg, 9mg, 0.9mg
0.9mg is the approximate dosage
98 is not an acceptable number; it has no unit
9.4.4mg is not acceptable; it is formatted wrong
9.7kg is fine, but 9.7kgasdfghjkl is not";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}