$re = '/(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)/m';
$str = 'Examples: 0.9 mg, 9 mg, 9mg, 0.9mg
0.9mg is the approximate dosage
98 is not an acceptable number; it has no unit
9.4.4mg is not acceptable; it is formatted wrong
9.7kg is fine, but 9.7kgasdfghjkl is not';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);