const regex = /(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d|\\.)\\d+(?:\\.\\d+)?\\s*?(?:mg|kg|ml|q\\.s\\.|ui|M|g|µg)(?!\\w)', 'gm')
const str = `Examples: 0.9 mg, 9 mg, 9mg, 0.9mg
0.9mg is the approximate dosage
98 is not an acceptable number; it has no unit
9.4.4mg is not acceptable; it is formatted wrong
9.7kg is fine, but 9.7kgasdfghjkl is not`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}