import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d|\\.)\\d+(?:\\.\\d+)?\\s*?(?:mg|kg|ml|q\\.s\\.|ui|M|g|µg)(?!\\w)";
final String string = "Examples: 0.9 mg, 9 mg, 9mg, 0.9mg\n"
+ "0.9mg is the approximate dosage \n"
+ "98 is not an acceptable number; it has no unit\n"
+ "9.4.4mg is not acceptable; it is formatted wrong\n"
+ "9.7kg is fine, but 9.7kgasdfghjkl is not";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}