import re
regex = re.compile(r"(?<!\d|\.)\d+(?:\.\d+)?\s*?(?:mg|kg|ml|q\.s\.|ui|M|g|µg)(?!\w)", flags=re.MULTILINE)
test_str = ("Examples: 0.9 mg, 9 mg, 9mg, 0.9mg\n"
"0.9mg is the approximate dosage \n"
"98 is not an acceptable number; it has no unit\n"
"9.4.4mg is not acceptable; it is formatted wrong\n"
"9.7kg is fine, but 9.7kgasdfghjkl is not")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")