const regex = /\.zip\b[^,]*(*SKIP)(*F)|\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.zip\\b[^,]*(*SKIP)(*F)|\\s', 'gm')
const str = `http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
`;
const subst = `%20`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);