import re
regex = re.compile(r"\.zip\b[^,]*(*SKIP)(*F)|\s", flags=re.MULTILINE)
test_str = ("http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt\n")
subst = "%20"
result = regex.sub(subst, test_str)
if result:
print(result)