$re = '/\.zip\b[^,]*(*SKIP)(*F)|\s/m';
$str = 'http://abcd.com/old file/anotherfile.zip/some contents/sample.txt,http://abcd.com/new file/anotherfile.zip/some more contents/new sample.txt,http://abcd.com/newer file/another file.zip/some more contents/old sample.txt,http://abcd.com/newer file/another file.txt
';
$subst = "%20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;