package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\bABCDEF\b`)
var str = `Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец`
var substitution = "\1AAA"
fmt.Println(re.ReplaceAllString(str, substitution))
}