import Foundation
let pattern = #"^(.*?)\bABCDEF\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1AAA"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)