$re = '/^(.*?)\bABCDEF\b/m';
$str = 'Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец';
$subst = "\1AAA";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;