use strict;
my $str = 'Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец';
my $regex = qr/^(.*?)\bABCDEF\b/mp;
my $subst = '\\1AAA';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";