re = /^(.*?)\bABCDEF\b/m
str = 'Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец'
subst = '\\1AAA'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result