const regex = new RegExp('^(.*?)\\bABCDEF\\b', 'gm')
const str = `Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец`;
const subst = `\1AAA`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);