// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)\bABCDEF\b").unwrap();
let string = "Текст, ещё текст ABCDEF ещё текст текст GHJKL -- много текста MNOP и напоследок снова ABCDEF конец";
let substitution = "\\1AAA";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}