#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$"
Local $sString = "Must match" & @CRLF & _
"----------" & @CRLF & _
"10.9.0.77" & @CRLF & _
"172.30.249.8" & @CRLF & _
"192.0.2.84" & @CRLF & _
"192.168.29.165" & @CRLF & _
"224.255.0.31" & @CRLF & _
"" & @CRLF & _
"Must not match" & @CRLF & _
"--------------" & @CRLF & _
"10.09.00.77" & @CRLF & _
"172.030.249.008" & @CRLF & _
"192.0.02.084" & @CRLF & _
"224.256.0.31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")