package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$`)
var str = `Must match
----------
10.9.0.77
172.30.249.8
192.0.2.84
192.168.29.165
224.255.0.31
Must not match
--------------
10.09.00.77
172.030.249.008
192.0.02.084
224.256.0.31`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}