$re = '/^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$/m';
$str = 'Must match
----------
10.9.0.77
172.30.249.8
192.0.2.84
192.168.29.165
224.255.0.31
Must not match
--------------
10.09.00.77
172.030.249.008
192.0.02.084
224.256.0.31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);