using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$";
string input = @"Must match
----------
10.9.0.77
172.30.249.8
192.0.2.84
192.168.29.165
224.255.0.31
Must not match
--------------
10.09.00.77
172.030.249.008
192.0.02.084
224.256.0.31";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}