import Foundation
let pattern = #"^((?:1\d|[1-9])?\d|2(?:[0-4]\d|5[0-5]))(?:\.(?1)){3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Must match
----------
10.9.0.77
172.30.249.8
192.0.2.84
192.168.29.165
224.255.0.31
Must not match
--------------
10.09.00.77
172.030.249.008
192.0.02.084
224.256.0.31
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)