import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:1\\d|[1-9])?\\d|2(?:[0-4]\\d|5[0-5]))(?:\\.(?1)){3}$";
final String string = "Must match\n"
+ "----------\n"
+ "10.9.0.77\n"
+ "172.30.249.8\n"
+ "192.0.2.84\n"
+ "192.168.29.165\n"
+ "224.255.0.31\n\n"
+ "Must not match\n"
+ "--------------\n"
+ "10.09.00.77\n"
+ "172.030.249.008\n"
+ "192.0.02.084\n"
+ "224.256.0.31";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}