# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])\1(\d)(\d)(?=[a-z])/<\1>\1<\2><\3>/gm;t' <<< "aa11bb123cc3333dd12eeeff3"