use strict;
my $str = 'aa11bb123cc3333dd12eeeff3';
my $regex = qr/([a-z])\1(\d)(\d)(?=[a-z])/mp;
my $subst = '<\\1>\\1<\\2><\\3>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";