$re = '/([a-z])\1(\d)(\d)(?=[a-z])/m';
$str = 'aa11bb123cc3333dd12eeeff3';
$subst = "<\1>\1<\2><\3>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;