import Foundation
let pattern = #"([a-z])\1(\d)(\d)(?=[a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aa11bb123cc3333dd12eeeff3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1>\1<\2><\3>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)