using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])\1(\d)(\d)(?=[a-z])";
string substitution = @"<\1>\1<\2><\3>";
string input = @"aa11bb123cc3333dd12eeeff3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}