re = /([a-z])\1(\d)(\d)(?=[a-z])/m
str = 'aa11bb123cc3333dd12eeeff3'
subst = '<\\1>\\1<\\2><\\3>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result