const regex = new RegExp('([a-z])\\1(\\d)(\\d)(?=[a-z])', 'gm')
const str = `aa11bb123cc3333dd12eeeff3`;
const subst = `<\1>\1<\2><\3>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);