using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\.\d+
.+?(?=\d+\.\d+|$)";
string input = @"1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}