$re = '/\b\d+\.\d+
.+?(?=\d+\.\d+|$)/x';
$str = '1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);