package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+\.\d+
.+?(?=\d+\.\d+|$)`)
var str = `1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}