const regex = new RegExp('\\b\\d+\\.\\d+
.+?(?=\\d+\\.\\d+|$)', 'g')
const str = `1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}