re = /\b\d+\.\d+
.+?(?=\d+\.\d+|$)/x
str = '1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end