import re
regex = re.compile(r"""
\b\d+\.\d+
.+?(?=\d+\.\d+|$)
""", flags=re.VERBOSE)
test_str = ("1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")