#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<path>([a-zA-Z0-9_-]+\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\/((?P<mode>[cs])\/)?((?P<quality>[0-9]{1,3})\/)?(?P<name>[a-zA-Z_\.-0-9]+\.[a-z]{3})"
Local $sString = "dev/earth/resized/100x100/s/70/earth.jpg" & @CRLF & _
"dev/earth/resized/100x100/70/earth.jpg" & @CRLF & _
"dev/earth/resized/100x100/s/earth.jpg" & @CRLF & _
"dev/earth/resized/100x100/earth.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")