const regex = /(?P<path>([a-zA-Z0-9_-]+\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\/((?P<mode>[cs])\/)?((?P<quality>[0-9]{1,3})\/)?(?P<name>[a-zA-Z_\.-0-9]+\.[a-z]{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<path>([a-zA-Z0-9_-]+\\\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\\\/((?P<mode>[cs])\\\/)?((?P<quality>[0-9]{1,3})\\\/)?(?P<name>[a-zA-Z_\\.-0-9]+\\.[a-z]{3})', 'gm')
const str = `dev/earth/resized/100x100/s/70/earth.jpg
dev/earth/resized/100x100/70/earth.jpg
dev/earth/resized/100x100/s/earth.jpg
dev/earth/resized/100x100/earth.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}